missing message window in Lazarus

General discussion about anything related to Ultibo.
develone
Posts: 308
Joined: Wed Dec 28, 2016 7:40 pm
Location: El Paso Tx USA

missing message window in Lazarus

Postby develone » Thu Apr 25, 2019 1:11 pm

Just updated with new ultiboinstaller.sh from Tools.
Can anyone help restoring my message window in Lazaraus?
Thanks in advance.
User avatar
Ultibo
Site Admin
Posts: 2255
Joined: Sat Dec 19, 2015 3:49 am
Location: Australia

Re: missing message window in Lazarus

Postby Ultibo » Thu Apr 25, 2019 11:54 pm

develone wrote:Can anyone help restoring my message window in Lazaraus?

We don't exactly know why this sometimes happens (something in the way Lazarus creates the default configuration) but there are a couple of things you can try to see if they work.

If the Messages window is not listed at all under the Window menu then try clicking View, Messages from the menu and see if it appears.

On the other hand if it is listed in the Window menu but not visible try selecting it from the Center a lost window option under the Window menu to bring it into view, if you can see it then you should be able to drag it and dock it at the bottom of the Lazarus editor.

If neither of those help then you can try opening the environmentoptions.xml file in a text editor (normally in $HOME/.ultibo/core/environmentoptions.xml) and removing the entire Desktops section, select everything from <Desktops Count="2" ActiveDesktop="default docked"> to </Desktops> and delete it then save the file and open Lazarus again which should recreate the default desktop configuration.

If you still don't have any luck let us know and we'll try again to reproduce the problem.
Ultibo.org | Make something amazing
https://ultibo.org
Gavinmc42
Posts: 1624
Joined: Sun Jun 05, 2016 12:38 pm
Location: Brisbane, Australia

Re: missing message window in Lazarus

Postby Gavinmc42 » Fri Apr 26, 2019 12:21 am

I have found if I rebuild the IDE the message window then appears.
- Tools- Rebuild Lazarus...
This has consistently fixed it in Linux Mint and on Pi's.
develone
Posts: 308
Joined: Wed Dec 28, 2016 7:40 pm
Location: El Paso Tx USA

Re: missing message window in Lazarus

Postby develone » Fri Apr 26, 2019 12:56 pm

Thanks for the help
Ultibo recommended several thing to try and none restored the message window.

We don't exactly know why this sometimes happens (something in the way Lazarus creates the default configuration) but there are a couple of things you can try to see if they work.

If the Messages window is not listed at all under the Window menu then try clicking View, Messages from the menu and see if it appears.

On the other hand if it is listed in the Window menu but not visible try selecting it from the Center a lost window option under the Window menu to bring it into view, if you can see it then you should be able to drag it and dock it at the bottom of the Lazarus editor.

If neither of those help then you can try opening the environmentoptions.xml file in a text editor (normally in $HOME/.ultibo/core/environmentoptions.xml) and removing the entire Desktops section, select everything from <Desktops Count="2" ActiveDesktop="default docked"> to </Desktops> and delete it then save the file and open Lazarus again which should recreate the default desktop configuration.

If you still don't have any luck let us know and we'll try again to reproduce the problem.


Removed ultibo & .ultibo folders and ran the ultiboinstaller.sh once more.

commit fd3955e6 Tue Apr 23 Tools
a3709d92b5072601d839d68afb25a83c Tools/Installer/Core/Linux/ultiboinstaller.sh

drwxr-xr-x 3 pi pi 4096 Apr 26 05:58 ultibo
drwxr-xr-x 3 pi pi 4096 Apr 26 06:24 .ultibo
Then I tested with the following command.
pi@mypi3-7wifi:~ $ ultibo/core/lazarus.sh. This was since I was running using ssh to the
the remote system.

The message window was okay. Opened a new project
https://github.com/develone/Ultibo_Proj ... 2_TFTP.lpi
The message window disappear.

Gavinmc42 wrote

I have found if I rebuild the IDE the message window then appears.
- Tools- Rebuild Lazarus...
This has consistently fixed it in Linux Mint and on Pi's.


Did not see where to rebuild the Lazarus in Lazarus or in the Tools repo.
develone
Posts: 308
Joined: Wed Dec 28, 2016 7:40 pm
Location: El Paso Tx USA

Re: missing message window in Lazarus

Postby develone » Fri Apr 26, 2019 3:14 pm

The problem appears to be related with the folder .ultiblo
pi@mypi3-4:~ $ rm -rf ultiboinstaller.sh .ultibo/ ultibo
pi@mypi3-4:~ $ ./ultiboinstaller.sh
ran using the desktop /Programming/Lazarus IDE (Ultibo Edition)
This creates the .ultibo folder
pi@mypi3-4:~ $ export PATH=/home/pi/ultibo/core/fpc/bin:$PATH
pi@mypi3-4:~ $ export PPC_CONFIG_PATH=/home/pi/ultibo/core/fpc/bin
pi@mypi3-4:~ $ echo $PATH
/home/pi/ultibo/core/fpc/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/games:/usr/games
pi@mypi3-4:~ $ echo $PPC_CONFIG_PATH
/home/pi/ultibo/core/fpc/bin
pi@mypi3-4:~ $ /home/pi/ultibo/core/lazarus

On another system I tried the steps but it did not help
This system does not have a monitor. Have to do everything ssh
pi@mypi3-7wifi:~ $ rm -rf .ultibo
pi@mypi3-7wifi:~ $ export PATH=/home/pi/ultibo/core/fpc/bin:$PATH
pi@mypi3-7wifi:~ $ export PPC_CONFIG_PATH=/home/pi/ultibo/core/fpc/bin
pi@mypi3-7wifi:~ $ echo $PATH
/home/pi/ultibo/core/fpc/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/games:/usr/games
pi@mypi3-7wifi:~ $ echo $PPC_CONFIG_PATH
/home/pi/ultibo/core/fpc/bin
pi@mypi3-4:~ $ /home/pi/ultibo/core/lazarus
pi@mypi3-7wifi:~ $ ls .ultibo/core/
editoroptions.xml includelinks.xml laz_indentation.pas
environmentoptions.xml inputhistory.xml packagefiles.xml
fpcdefines.xml lazarus.dci projectsessions
User avatar
Ultibo
Site Admin
Posts: 2255
Joined: Sat Dec 19, 2015 3:49 am
Location: Australia

Re: missing message window in Lazarus

Postby Ultibo » Sat Apr 27, 2019 12:10 am

develone wrote:The message window was okay. Opened a new project
https://github.com/develone/Ultibo_Proj ... 2_TFTP.lpi
The message window disappear.

Normally at this point the message window will appear as soon as you click Run, Build from the menu. In fact if I close the message window it always reappears when I compile or build the project.

Just to confirm, you are using Raspbian for this?
Ultibo.org | Make something amazing
https://ultibo.org

Return to “Discussion”

Who is online

Users browsing this forum: dieselnutjob and 1 guest